Win7 calls every .exe a windows media center application

I was fixing my cousins laptop via teamviewer.

The problem is that every thing opens with widows media center. Many shortcuts icons have changed to windows media center and every .exe calls this windows media center.

I tried a lot to fix it but didn't succeed.

Local group policy editor is not available in windows 7 home edition. So, gpedit.msc doesn't work.

And I also disabled/manual/automatic all three options of windows media center but that also didn't worked.

I also downloaded a anti-spyware from filehippo but that .exe will also call windows media center. Shift+right click doesn't work in case of shortcuts of skype etc. programs.

Although videos which I run in VLC mdia player do work and also with shift+right click open with option.

Any solution?


well noone replied and I took a risk and implemented my own solution on Windows 7 home edition.

Default File Type Associations Restored through these registry files of Vista 64 bit.

Here's How:

1. Click on the file extension type link listed below for the one that you wish to restore to default to download it's .zip file.

2. Save the .zip file to your desktop.

3. Open the .zip file, then extract the .reg file to the desktop.

4. Right click on the .reg file and click on Merge.

5. Click on the Run button in the Security Warning pop-up.

6. Click on Continue (UAC), Yes, and OK when prompted.

7. When done, you can delete the downloaded .zip and .reg files on the desktop if you like.

Default Vista File Extension Types are available on the above link.

The title didnt specify if you needed help.

If title was:

"Win7 calls every .exe a windows media center application"

Then maybe someone may have helped. Anyhow, this must have been a good experience for ya.

^yup agree.

thanks mate..i was having this file association problem for quite some months.....i also started a thread here after googling alot back then...! but now every thing is neat and clean.!

^Did you noticed one thing, the propeties of the drives are now not showing the disk cleanup option. Not only disk cleanup button but also some more tabs in the properties of the drives.

Now I have to fix that also.

Any idea?