WebEx blocked by PTA, WC or other ISP's?


I can't load the secure webpage (keeps timing out) to register for a webex event when i use firefox (one of webex's approved browsers). However, I can load the page and register for the event if I go through tor (cough, cough). But then the event manager won't launch (maybe because it's not friendly with the firefox portable version bundled with tor).

I'm at a loss here folks. I'm not very technical so I don't really know what to do, except apologize to the event organizers (and leave them with a bad impression of pakistan and pakistanis) and communicate via emails with attachments.

Any ideas why this happened, and how to avoid it in the future?



Can you load other secure websits?

Did you try other browsers?

Did you try on another computer and/or internet connection?

There shouldn't be any reason to ban WebEx. I'm guessing your browser/OS is just not firing up the JVM properly or something like that.


i can load other secure webpages

i tried opera (but it's not supported by webex so didn't expect it to work), tried latest v of firefox (failed due to timeout), might try chrome, might bite the big ecchhy bullet and install win explorer

haven't tried either another console/computer or another connection

so, off to troubleshooting land i go.

thanks for all your suggestions



You need Java for WebEx. The last time I used WebEx was... during the summers, and it worked fine.

Just an hour ago, I was seeing a recording of a WebEx event I missed.

PS: I'm on Micronet/Nayatel. Who's your ISP?