Pyridine modem Fucked up!

Okay here is the deal i have this Pyridine (Zhone) modem but it was going buggy i guess so i tried updating the firmware but the light was out during the operation and now modem is out of order. it doesn't syncs and i can't go to so can anybody help me how to make it working again?

You can check this thread. If it also serves as a router, chances are you'll be able to recover the bricked device using RouterTech custom firmware. Go to their website, and download Router Repair Tool, along with copy of firmware v2.93 that closely matches your modem/router specs. You won't be able to perform an upgrade check since the modem is already bricked, so you can take chances and go ahead with firmware that closely matches your modem description. Check their forums for further guidance on unbricking. I too messed up with my router but then was able to unbrick it successfully using the same. Good luck!

Alternatively, you can use PCTool or a similar utility to flash your firmware onto your modem. Go through some tutorials on using PCTool, etc. before you attempt so.

Note: Try at your own risk as it may render your device completely useless.

not much useful, i tried using the short circuit thing also but modem is not responding only power and activity light shows up!

What is the bootloader type? Any idea?

Can you send me a snap of the PCB of the modem? Of course, you will have to open the plastic housing to unveil the board.

RT firmware works for psp and adam bootloaders only. I might be able to guide you after viewing the chips on the board.

Were you able to connect via PC Tool?

oops, i really forgot about it, anybody still up for solving the problem? only power led is on, it doesnt connect via Usb or Ethernet

Here are the board images