PTCL CharJi problem

I got a new CharJi yesterday. Since then, something strange has been happening to my computer's Internet connectivity.

1. I ran "autorun.exe" in device, labelled "MiFi" driver. It did nothing, just showed a notification in the system tray with a lot of garbage left me feeling uneasy but virus scans seem to be clear.

2. The computer eventually detected my CharJi in the list of wireless networks. However, I cannot connect to it--there is a red cross.

3. I checked my settings, etc, and nothing seems to have been changed.

4. It is able to connect some other wireless networks too, but if I connect the CharJi to it via USB, it can't detect any wireless network (previously, it used to be able to do that even when I connected my previous CharJi via USB).

5. Connecting via USB is the only way to use this CharJi, which I think is ridiculous since this is supposed to be a mobile wifi hotspot.

6. That junk driver autorun.exe doesn't seem to have installed any program that I can see...

My mobile is able to connect to the CharJi through WiFi...I have a feeling the junk driver messed up something in my laptop.

What do I do? PTCL customer support says that since other devices can connect to this CharJi, it is working correctly and the problem is in my computer hence not their issue. Nothing else has changed in my computer besides the stupid program that their device asked me to run.

Make sure that:

1 - Wifi is enabled (via hardware switch) on the laptop.

2 - Delete all existing wireless connection profiles using the same/similar name.

3 - Make sure IP, gateway and DNS assignment for wireless connection is set to DHCP. If it still doesn't work, try assigning a static IP, gateway, DNS from Charji wifi network subnet.

4 - Boot into safemode with networking and see if it works (via DHCP assignment).

5 - If everything else fails, uninstall/delete wifi device/chip drivers and install WHQL certified drivers (preferably via Windows Update or from manufacturer's drivers page).

Check Your DNS

Thats usually changed to Cyberghost or Hotspot DNS Servers. Change it to Default Auto.