Please Help Problems sharing world call cable internet

OK I'm having problems sharing my worldcall connection, I have a linksys ADSL wag200g, never had any problems with PTCL now when i connect worldcall internet through this it sometimes works with wifi sometimes it does not, I have two computers that I need to share the connection on, both desktops and both are wired- no wireless. I have tried this modem router, works on one computer doesnt on the other sometimes doesnt even work on one computer, I have tried a hub, I'm getting frustrated, any ideas how I can use the internet on both computers i'm not too much of a techy and this one guy suggested a weird solution and was charging over a 1000 rs. PLEASE HELP!!!

ps. I'v also tried a dlink 512 router which is available all over lahore but same issue with that - sometimes it works but most times it doesnt.

You haven't specified the dlink router model number so I can't help you with that.

With regard to the linksys router, that can only be used for sharing a DSL connection. What you need is a general purpose router that can share any internet connection that is delivered to it via an Ethernet connection. You can get wireless routers like these starting from Rs. 1600. They also have wired ethernet ports for connecting via patch cable. Example:

However I'd like to point out that sharing a World call connection can be troublesome because of the way they renew IP addresses. I bought a used wired ethernet router and sometimes it would fail to renew the connection and I would have to manually do it via the browser interface. So try and test any router before you buy it. Perhaps borrow one from a friend.

I'm using TP-Link TL-WR940N the one with 3 antennas and N protocol. Right now i'm trying to connect via the lan port so no wireless connection right now


It autodetects that worldcall is assigning static ip. Which i believe is incorrect. I have tried static ip and dynamic ip and both don't work. I'm able to connect to my router but my router doesn't connect to the internet.

In which port of the router did you plug in the worldcall cable? You should plug in the ethernet patch cable from the worldcall router into the WAN port of the router. That is usually the blue coloured port. If you plugged it into one of 4 LAN ports it won't work. You must then plug in your own computer ethernet cable into one of the LAN ports.

I suggest you hit the reset button on the back of the router to return it to factory default settings. Then connect it like I mentioned above and it will work.

yes the cable from the cable modem is connected to the WAN port and computer connected to the LAN port. I am able to see the setup page at and run quick setup, yet no setting either dynamic ip nor static ip works. Is their a special settings info regarding worldcall that i need to input in the router settings page

going to reset the router and try again.

When i run the easy setup assistant it says that the DNCP server needs to be enabled in the router.

Shouldn't the easy setup do this by itself. Whats the point of easy setup if i have manually configure the router. which btw doesn't work either.

Can someone please post the settings they have used for worldcall in the tplink configuration pages

ok got it working on


You're welcome. But you know what would be really great? If you would please tell us what you did to make it work so that others could learn from your experience.