Only Google Play not working while others are working on PTCL DSL

Since 3-4 days Google Play is not accessible and its apps are not updating or downloading via

PTCL 2 MB DSL ay my home. Other internet related activity on mobile is working. Need help. Thanks

i tried to enter address under Use the following Static DNS IP address:

but it continuously re back to Select DNS Server Interface from available WAN interfaces:

also tried to enter settings in individual mobile set, but no use.
Only by using vpn like cyberghost solves the problem.

You can probably tell the Router which DNS servers to give to connecting machines. Try the web interface for your wifi router.


I don't know why but allowing auto-rotation and then putting the device in landscape mode almost always solves this issue for me (the issue occurs rarely for me though) ... likely caused by blockage of ips belonging to google by the 'firewall' put up by pta! Do try this method ... maybe it'll work for you!



It is now working.

Thanks to all.