Linux and Wateen USB + Misc info

After PTCL has imposed ridiculously small caps on their evdo now, I am looking for alternatives. Wateen seems like the best choice as I can only have wireless and need an unlimited connection. I confirmed from their helpline that they don't have a fair usage policy of a sort, and its unlimited (I would like some heavy downloaders to confirm this though). Its 1500/month, including the rental for the USB modem. He said that advance/security is 1500, so 3000 and I will have the connection.

I asked for the USB model of the modem as I wanted to search if the device will work in Linux (its ZTE AX320 according to the rep). I couldn't find much about it on internet, so I was wondering if someone who is using the device and has Linux installed on their system check the compatibility, or at least tell me the vendor and device ID of it (In terminal, "lsusb"). And on a side-note how much will the CPE will cost, how does the USB connect (a dialup sort of connection)? and is the IP static or dynamic.

Plus, I would really like some comments about its speed in Anarkali/Islampura area of Lahore.

Islampura area is great, one of my cousin is using the moto usb of wateen and it works awesome there

and for the download it is definitely unlimited i am using there Motorola wifi device which in short is called blade 2 and there is no such things as fair usage policy i have multiple months for this confirmation and for the current month i have used the total bandwidth of 40.9 GB and still pushing on by the way torrents sucks as there is a throttling from 12 pm to 2 am otherwise all is well

the usb connects through a software and there will be no dial up connection it works the pretty same way as evo connects on usb you wont get a static ip on dynamic will be allotted

and as for Linux sorry bro don't have that info :)

Thanks for the information. So far so good apparently. BTW when I asked about their devices, both models the rep told me were of ZTE. The one I mentioned was USB, there was another (ix something) he told me, which I am guessing is like a modem + router which will connect through the Ethernet port, in which case there is no Linux compatibility problem, but I have a feeling that for that, upfront cost will be higher.

And EVO connects via dialup. The software they supply makes a Dialup connection in the back-end as its basically vWireless network.

Edit: Just called their help line. The monthly charges with the Indoor CPE device are ~1700. If I don't get some info about the USB modem till Monday, I will have to go with the CPE as its still 500 less monthly than the liars, aka ptcl, and with no cap.

Try to get buckeye device. Its performance is very good compared to other devices.

Not sure about Linux compatibility.

I am not sure about the USB drivers for Linux because I didn't use that USB Modem.

but I can advise to go for any CPE with the Ethernet if you are gonna use the services "AT ONE PLACE".

I suppose the ZTE AX320 is a USB Stick with internal modem but not a standalone modem with a USB connectivity support (which you usually use with USB Cable in addition). And if it's a standalone modem then of course you don't need it and preferring the Ethernet over it is most viable.

I also searched about it and when I couldn't find some thing on the web which is available in Pakistan, I only blame the providers that they always use the cheap devices here which have been rejected in the world around us. It's ridiculous when you can't find any thing about a specific device on the web.... Any ways.

other thing with the Wateen is that you will get a dynamic IP with the package but if you consider to buy a Static one, you can order for that right away but preferably buy that later after using and testing the service.

Don't buy either of ZTE devices. They overheat and hang from time to time. I'm using ZTE IX380 router. They insisted on providing usb, but i got the router, no such hassle for linux. Be warned though, that wateen throttles torrents, you won't cross 20K/s on even private trackers. You will only receive full speed on torrents after 2:00 AM.

I'm trying to get back to PTCL, but my line is #$%^&# up beyond repair and nobody's got a freakin' clue about it :@...

[quote=", post:, topic:"]

Don’t buy either of ZTE devices. They overheat and hang from time to time. I’m using ZTE IX380 router. They insisted on providing usb, but i got the router, no such hassle for linux. Be warned though, that wateen throttles torrents, you won’t cross 20K/s on even private trackers. You will only receive full speed on torrents after 2:00 AM.

I’m trying to get back to PTCL, but my line is #$%^ up beyond repair and nobody’s got a freakin’ clue about it :@…


Use encryption it does help in some cases.


Buckeye device? Is that a company name or a nickname of device, because I couldn't find anything about it on Internet :)


I am going to use the services at only one place. The only reason I was going for the USB is because of low power consumption and 200 per month less rental. And I agree on the devices being the cheap ones, with no documentation or support available for them. But the thing is that these devices still use some generic/popular chipset for which there mostly is a driver in Linux. Like my Huawei EC360 is a PCMCIA modem, but in Linux is is detected as a E620 USB modem (Internally the Chipset huawei uses is a USB one, for which they added an NEC USB controller apparently), but it works fine. So if I had the Vendor and device ID of Wateen's USB modem, I could have looked it up to see which chipset it has got.


I will see if their franchise has some other CPE. And I don't use torrents anyway, so its fine.

Got the Motorola CPE 3 hours ago. The franchise CSR told me to call him and confirm that I am getting signals, after which I had to call another number to get the device activated. The device is definitely not new, which means someone had returned it. I called the activation number, and after giving all the details, he said there is an error activating it, and I should call their Help line. I called and registered complaint there, and he said it will be resolved within 24 hours. Though I had already gotten a username/password on my cell, so I tried connecting, but I got a page saying that the Device's MAC does not match the ID in their records, and I need to send my ID, MAC, IP and CNIC another mobile number.

Now I am waiting to see how long it takes for my ID to get updated with the MAC of this device, after which I will post the speed result. I am getting 2-3 bars at the moment.

By Motorola CPE do you mean the Ethernet device or the USB one?

Yup the Ethernet one man. As I couldn't get any info on the USB modem and I have to use on Linux (Though I am pretty sure it would have worked), so I went with Ethernet one. Its Motorola i35775. I am getting 3 signals at only one specific spot in the room, I hope I will get constant ~1Mb speed.

Just tried it and its working. Though I didn't have to enter my username and password anywhere. I guess they bind it themselves to the device's MAC at backend?

Speed is good at the moment. But the main problem I had with PTCL was peak hours, so will post update tomorrow. evening and night


I turned off the device and then turned it back on, to see if I get a different IP, but I didn't. Didn't Wateen give dynamic IP?

Isn't this too much speed :P


Wateen gives Dynamic IP but the lease time is ~3 hours. What's your uplink speed now ? post your speedtest result.

^ Yeah I noticed the IP change after a couple of hours, but I was hoping there will be a way to renew it manually. I will try to edit the lease time option in configuration to see if it makes any difference, once the network comes back up.

Is no one else here affected by their network failure?. I used it for a day when I bought it, and then I am using it just now, but there are no signals at the moment. I called their help line, but right at the beginning they have added an announcement that "Internet and Telephony services are temporarily unavailable for some customers in central and north region, our staff is trying to resume the service.'"

please share the performance in peak timings.

from 1pm to 1am the downloading speed is not more than 50kb/s.

There service drops from 1Mbps to 256Kbps for me in the peak hours. I only get 1Mbps speed after 2:00 AM. Glad to be back on ptcl (after resolving the main culprit ofcourse) after the horrors I've been through these past 2 months.

^ This exactly was the case for me with PTCL Evdo. From early morning to about 12Pm it would give ~1Mb, after which it would crawl to ~256Kb - 512Kb. Previously it used to give 2Mb in another location about 4KM away from here, but tonight I tested it there, and it literally opened JUST 4 web pages in 1 whole hour, testing the speed was out of the question.

I hope that Wimax connections are not shared like EVDO was (3.1Mb for the whole tower), in which case most users should get at least close their package speeds if they are getting good signals. In my area at least, I am not facing a lot of speed variation. I pray and hope that it will stay this way, as I am out of options if this connection starts to suck as well.





P.S: I had noticed that their upload speed was capped at 256Kb first, but not it is going well above that.

I called the help line and the CSR told me that the wateen connection is shared 1:5.

That's why we are facing this slow speed.