How to get PTCL Dsl work with TP-Link TD-8840T Modem?

Well, I`ve just bought a TP-Link Modem + Router (TD-8840T) in place of my crappy Shiro Modem but never had any idea how get it work with PTCL. Any one plz guide me though the process. Help will be highly appreciated.

Well its quit easy if u know how to work on modem make the connection in bridge mode.

Then on router just configure it as pppoe enter your user password in it.

I tried the CD which came along with the modem for easy setup. It asks for the connection type. I chose bridge connection but had a problem. I could not find PPPOE in the web manager where i could enter my User name & password. I then again tried to configure the modem using the easy installation CD & this time selected PPPOE as the connection type. This time I was asked to enter my user name & password which was indeed entered correctly.But this all cant seem to work properly, something is missing. I cant use the internet. If anyone have a video or complete guide how to get it working please let me know. I am not a network geek but would love to learn some basics. My damn Shiro keeps disconnecting all the time, which caused me to wait half an hour to get this message posted.

You can also try setting up Dynamic IP in your TP LINK ROUTER and than connect the ethernet cable in the WAN of tplink and LAN of PTCL modem. But first change the network-->LAN---> ip address of your TPLINK to before connecting TPLINK to your PTCL modem. Its done

I looked for WAN on the device but did not find any. Its ADSL2+ Modem. Here ( as you can see in the image. Full description of the product can be see here ( My Shiro Modem is really killing me now, disconnects every time. I really want to use my new device instead of Shiro.

Ok connect the telephone wire the line port and than connect your PC in the lan port. Open and in advanced WAN settings enter your ptcl user name and password. Usually user name is 0213XXXXXXX and pass is PTCL. Enter 0/103 IN VPI/VCI if on copper else 0/35 on fiber optic. Choose PPPOA/PPPOE as connection type. Thats it

Thanks basitnamdar, i am looking forward to your advice, will post back with result. Thanks bro.

Works fine although I would like a solution that can give wireless connectivity in the entire house. Any ideas ?