Help configuring DSL modem in bridge mode

I have a PTCL broadband connection. The DSL modem I have is a ZTE 831 Series, it is connected to my D-Link router DIR-655. Initially, I had set up the modem to connect to the Internet, but now I want to put it in bridge mode and have the router connect to the Internet. The reason I want to do this is that I was having port forwarding issues with the router and I went over to the D-Link support page and they suggested putting the modem in bridge mode.

I have configured the modem to work in bridge mode, but I cannot get my router to initiate the Internet connection.

Below is a sample Internet configuration page from the DIR 655.

image hosting websites

The settings I am using are...


Address mode: Dynamic IP
Username: xxxxxxxx
Password: ptcl
Service name:
Reconnect mode: Always on
Primary DNS address:
Secondary DNS address:
MTU: 1492
MAC address: (my DSL modem's mac address)

But I can't get the router to make the connection. Can someone please help me get this working.

You are confusing your router for an ADSL2+ modem itself, which it probably is not.

Only your ZTE modem can initiate the connection. The PPPoE connection details present in you router page are for other types of connections which are a separate discussion.

The wireless router can initiate the connection as long as the modem is in bridge mode. I've done it before, but now it's not working. I am not really sure what I am doing wrong.

The Internet light on the modem blinks a few times, then it stops, it starts blinking again after a pause and then it stops again. The same process keeps repeating, but the wireless router is unable to connect to the Internet.

I finally got the dsl modem working in bridge mode. Everything started working after I did a factory reset on the router.

[quote=“blodlust, post:4, topic:20604”]

I finally got the dsl modem working in bridge mode. Everything started working after I did a factory reset on the router.


well, its quite an old post. but thats exactly what i am trying to do. Use tplink device as router. For which i have put the device in PPPOE mode and feeded my username and password. but still it is not connecting. i have tried resetting the device. confirming my username and pass from PTCL and etc etc everything. but still it is not connecting. i tried an other tplink router i have, still no luck it also doesnt connects.

I have configured my modem in bridge mode. And TPlink router is working now.