Attn PTCL Users: SEA-Me-We4 Under Repair

So this morning I decided to visit IPTorrents/TorrentLeech as an early morning routine but I'm welcomed by the OpenDNS (website blocked, listed in peer2peer/filesharing) message instead of those sites' homepages.


I use openDNS at home myself but this blockage is coming from a higher level i.e. ptcl since they havce a stupid avatar/icon on the openDNS blockage page and it's definitely someone fingering with our net access on ptcl level.

Someone please confirm if this is happening to other ptcl members too? (pindi/isloo preferably).

I'm definitely switching if these chimps think they can block my access to certain sites and still get a chunk of my paycheque.

UPDATE: so 10 minutes later, it seems ptcl has toned down the filter and torrent sites now open - probably some partially-skilled admin was trying to understand how this whole filtering thing work.

Use Google DNS.

^ oh yes! , that'll come in handy if they try to block again :P

I am/have been using the DNS assigned by PTCL.... no problem what so ever here regarding DNS.

Its a problem with openDNS. I had experienced this too. Use either PTCL's DNS or Google's.

Using PTCL and Google DNS. No Problem with Torrent or P2P Sites here.

I cannot download a single *.torrent file on my connection. Tried multiple website's and multiple pc's and was not able to download a single torrent file on my connection.

Is PTCL trying some funny business here? Can someone check this?

okay let me check it for you


No Prob here on Ptcl works everything good just updated utorrent

same here...its definitely PTCL

Not only that I can't download torrent files...none of the torrents in my download queue are working

ptcl blocking all the trackers i think , some of trackers are not working in my utorrent client and also some private torrent sites are not opening right now

i think we are being capped by PTCL!!..........Those morons :angry::angry:

Suddenly all of my torrents turned red too.... but after a restart. its all good. I don't think PTCL is throttling. might be hiccup in service at PTCL's side.

PTCL has definately blocked the downloading of any file with the 'torrent' extension and also blocked a few trackers (thepiratebay, openbittorrent) but only on their new dslam (within the IP ranges of 182.183.*.*)


They are having a hard time trying to figure out if they want to block torrents or not perhaps. For a while everything is blocked then its not, which made me think this had to do something with the new IP ranges.

If they are blocking *.torrent file, then you can try downloading the that torrent file as text file. almost all trackers have this option. after dloading the text file, just change the extension from txt to torrent.

I faced same problem this morning but it was automatically resolved after half an hour. It appears to be a temporary glitch.

i called and asked the ptcl people,

the call was taken by a HAWT :D voice after some 20mins of ridiculous "inteha-e-intezar" :angry:

then i told her that i was having troubles since last night with my torrent etc. she didnt know about torrent so she transffered the call to senior support. after more than 20 mins the senior support chick picked up(her voice wasnt good, she sounded like a tranny in pain :unsure: ) and told me tht ptcl hasnt blocked any site but they're having issues with some bittorrent sites. and as soon as the issue is resolved they'll send me an email/ call me etc...


Iam having an error while opening a Torrent File that "Torrent is not valid bencoding" , so is this PTCL's fault ? And how to use PTCL or Google DNS ??

@ Ozmayne

I am also facing the same problem. .torrent files are not downloading or opening. any solution ?

Same here. Torrents are mightily #$%^. Can download torrents but at abysmal 20KB/s speed. Perhaps we can get an explanation from firecruz?

Same problem here. I switched from wi-tribe to PTCL purely for torrents and now this. I am majorly disappointed, if it's going to stay this way then there's no point having a 4 mb connection. .torrent files from all public trackers and private trackers I've tried are blocked. Even if it does download, I get no connections to seeders and a measly speed of 0.2kb/s. Interestingly, I tried a torrent last night which worked. They might be following a similar strategy to wi-tribe (throttling torrents during the daytime).