Atmel AVR USBasp Problem

Hi, I am having problem in burning program in avr microcontrollers by using usbasp v2 programmer. I read all forums but not found any solution. Whenever I tried to burn the chip it gots this message

_avrdude -p atmega32 -P usb -c usbasp -U flash:w:Sample.hex _

avrdude: warning: cannot set sck period. please check for usbasp firmware update.
avrdude: error: programm enable: target doesn’t answer. 1 _
avrdude: initialization failed, rc=-1
_ Double check connections and try again, or use -F to override

_ this check._

avrdude done. Thank you.

make.exe: *** [program] Error 1

The connection I made by follow the below picture.


Anyone having experienced in using usbasp please tell me about connections, is it correct or wrong.

Have you tried programming other micro-controllers (same part number and others)? What was result?

Yes, I tried other parts as well.

And was it successful?

Have you tried another programmer?

Did you diy the ckt or get one from the market.

I had faced the same problem about 2 yrs ago, but forget the various solutions I tried. I don’t recall what the details were, right now, but the one I remember was the crystal frequency is important.


Did you figure it out.