Wifi on sony vaio pcg-tr3 (successfully done)


#1

Has anybody tried wifi on this netbook ? It isn't working for me did tried the drivers from this site but to no avail http://esupport.sony.com/US/perl/swu-list.pl?mdl=PCGTR3A


#2

Have you entered the mac address on the wifi router ?


#3

I don't have a wifi router, also I download VGF-WA1 Wireless Adapter Manager and it says no wireless adapter found. I'm trying to setup a Wireless ad hoc network.

The wireless lan light does light up.

Here is the dev man scrnshot networkcontroller.jpg

Uploaded with ImageShack.us


#4

I have succefully setup a adhoc network between the two laptop how do i share the Internet connection ? I'm using Internet on windows 7 laptop and want share it with windows xp connectednetworkwifi.th.jpg

Uploaded with ImageShack.us


#5

in windows 7 simply open status of your internet connection from task bar, open properties, and from the sharing tab, check the the first option and select the wireless adhoc connection, click ok and youre done

now in windows xp set the adhoc connection tcp ip settings to automatic.


#6

The wireless adhoc connection option is not there in the Internet connection sharing. You see Windows 7 is identifying them as separate networks networka.jpg

By yousaf465 at 2010-09-19


#7

Its obvious they are separate networks, so windows will identify them as separate networks.

I don't think you opened the correct properties

Open the properties of you INTERNET CONNECTION, and enable sharing in it. Then select the connection(wireless adhoc connection) you want to share your internet connection with.

captureqz.png


#8

Yeah I that is the what I meant when I said

[quote=", post:, topic:"]
The wireless adhoc connection option is not there in the Internet connection sharing.
[/quote]

I'm using a modem with USB

usbandwifi.jpg

Uploaded with ImageShack.us

networkprop.jpg

Uploaded with ImageShack.us


#9

It's working now thanks God. I'm on roof of my two storey house and Internet is working pretty awesome. WOw. wifiontopoftheroof.th.jpg

On rooftop non-LOS with a torrent downloading on main machine 1 MB connection

Facing some disconnections dhcpassignedip.th.jpg


#10

Now I'm getting ip in this range 169.254.x.y. Also select a private network is not ava as you mentioned in #7 post

Here is the screenshot

accuriedwrongip.th.png

Here is the nslookup , when it it said connected.

nslookup.th.jpg

Uploaded with ImageShack.us


#11

Well this will help

C:\Documents and Settings\compname>ipconfig /renew

Windows IP Configuration

No operation can be performed on Local Area Connection 3 while it has its media

disconnected.

An error occurred while renewing interface Wireless Network Connection : unable

to contact your DHCP server. Request has timed out.


#12

I connected in Fedora (linux), working fine with this result. 10.42.43.1 for the host and 10.42.43.10 for the client running windows xp. Used shared to other computer in method for IPV4 setting.

ifconfig

[liveuser@localhost ~]$ ifconfig

eth0 Link encap:Ethernet HWaddr 00:30:0A:AF:BA:D6

      inet addr:192.168.1.6  Bcast:192.168.1.255  Mask:255.255.255.0

      inet6 addr: fe80::230:aff:feaf:bad6/64 Scope:Link

      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

      RX packets:27665 errors:0 dropped:0 overruns:0 frame:0

      TX packets:34322 errors:0 dropped:0 overruns:0 carrier:0

      collisions:0 txqueuelen:1000

      RX bytes:20412861 (19.4 MiB)  TX bytes:11815939 (11.2 MiB)

eth1 Link encap:Ethernet HWaddr 00:12:F0:27:5A:37

      inet addr:10.42.43.1  Bcast:10.42.43.255  Mask:255.255.255.0

      inet6 addr: fe80::212:f0ff:fe27:5a37/64 Scope:Link

      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

      RX packets:11923 errors:0 dropped:0 overruns:0 frame:0

      TX packets:7536 errors:0 dropped:5 overruns:0 carrier:0

      collisions:0 txqueuelen:1000

      RX bytes:8949521 (8.5 MiB)  TX bytes:13174731 (12.5 MiB)

      Interrupt:17 Base address:0x6000 Memory:dfdfd000-dfdfdfff

eth2 Link encap:Ethernet HWaddr 00:11:43:72:AC:3A

      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

      RX packets:0 errors:0 dropped:0 overruns:0 frame:0

      TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

      collisions:0 txqueuelen:1000

      RX bytes:0 (0.0   TX bytes:0 (0.0 

      Interrupt:18

lo Link encap:Local Loopback

      inet addr:127.0.0.1  Mask:255.0.0.0

      inet6 addr: ::1/128 Scope:Host

      UP LOOPBACK RUNNING  MTU:16436  Metric:1

      RX packets:14 errors:0 dropped:0 overruns:0 frame:0

      TX packets:14 errors:0 dropped:0 overruns:0 carrier:0

      collisions:0 txqueuelen:0

      RX bytes:900 (900.0   TX bytes:900 (900.0 

</pre><div>

Iwconfig gave this

liveuser@localhost ~]$ iwconfig

lo no wireless extensions.

eth0 no wireless extensions.

eth1 IEEE 802.11b ESSID:“modem”

      Mode:Ad-Hoc  Frequency:2.412 GHz  Cell: 02:12:F0:15:10:62  

      Bit Rate:11 Mb/s   Tx-Power=20 dBm   Sensitivity=8/0  

      Retry limit:7   RTS thr:off   Fragment thr:off

      Power Management:off

      Link Quality=97/100  Signal level=-27 dBm  Noise level=-85 dBm

      Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0

      Tx excessive retries:2  Invalid misc:0   Missed beacon:0

eth2 no wireless extensions.

pan0 no wireless extensions.

ps aux | grep dnsmasq gave the follwoing

[liveuser@localhost ~]$ ps aux | grep dnsmasq

nobody 4876 0.0 0.0 2352 892 ? S 12:46 0:00 /usr/sbin/dnsmasq --no-hosts --keep-in-foreground --bind-interfaces --no-poll --except-interface=lo --listen-address=10.42.43.1 --dhcp-range=10.42.43.10,10.42.43.100,60m --dhcp-option=option:router,10.42.43.1 --dhcp-lease-max=50 --pid-file=/var/run/nm-dnsmasq-eth1.pid

liveuser 5316 0.0 0.0 4200 728 pts/0 S+ 13:58 0:00 grep dnsmasq

Fore further info check http://fedorasolved.org/Members/dcr226/internet-connection-sharing-over-wifi-with-fedora and http://linuxers.org/howto/how-setup-home-network-internet-sharing-linux-ubuntufedora-using-network-manager.

But … My problem is still there. restoring to an adhoc ICS on Windows 7