VPN not works when DHCP enabled


#1

PPTP VPN get connects but status says No Internet Access when DHCP is enabled in router but when i disable it VPN works fine , problem is i need to keep DHCP enabled so roter automatically assign IPs to new devices... and VPN also works..

Windows 7

connection to router is via wifi


#2

Which router/modem devices?


#3

[quote=“Asad, post:2, topic:21962”]

Which router/modem devices?

[/quote]

Huawei B593u-12


#4

[quote=“armada, post:3, topic:21962”]

Huawei B593u-12

[/quote]

Does it have IPSec/PPTP/L2TP passthrough options?


#5

[quote=“Asad, post:4, topic:21962”]

Huawei B593u-12

Does it have IPSec/PPTP/L2TP passthrough options?

[/quote]
it has no vpn settings in firmware … problem is with Windows VPN connection, because on other Android devices connected with router has no issues when connection made to vpn even though DHCP is enabled…

#6

why dont you just assign a static IP to your Windows PC.

Then it wont be using or needing DHCP.


#7

[quote=“ShoukaT, post:6, topic:21962”]

why dont you just assign a static IP to your Windows PC.
Then it wont be using or needing DHCP.
[/quote]
There are other devices need to be connected and if dhcp disabled router doesn’t assign addresses and they stuck at obtaining ip

#8

[quote=“armada, post:7, topic:21962”]

There are other devices need to be connected and if dhcp disabled router doesn't assign addresses and they stuck at obtaining ip

[/quote]

I am not saying disable router DHCP.

I am saying just assign static IP address to your PC from the TCP/IPv4 setting in the network adapter settings.

Then your PC won't use DHCP.

seems more like your PC problem.

you should try to replicate the problem on a different laptop/PC.

or on a Virtual Machine (set the networking as bridged)


#9

Assign a static IP to the PC from router DHCP settings.


#10

these are the images on router DHCP settings..what settings need to be done in here for VPN to work fine

further settings


#11

Make a reserved address entry for your PC using PC's MAC address.


#12

what difference will it makes?


#13

couldn't solve the issue, now set DHCP disabled and manually allocated IPs to each device

this is some serious issue with win 7 cuz when i hit google with this issue there are tons of posts related to this even at Microsoft Q&A forum


#14

Tried uninstalling/updating the network adapter drivers?


#15

too lazy to do that


#16

Problem Solved by returning to XP :wacko: