USB Flash Drive appearing as HDD instead of Removable Device


#1

It's a very first experience for me... also just finished searching Google and didn't find a good help to fix it...

It's 4GB and is just appearing besides the HDD drives in Hard Disk Drives section. I need it to appear in Removable Storage section.

Any clue?


#2

--


#3

Oh. Thats strange. I have been looking for a way to do just that for a number of months. How did you manage to do it? Any idea? I want the USB to appear as a Hard Drive since i want to use USBs at my workplace for sharing files with coworkers. USBs are blocked at my office but USB Hard Disks are not.


#4

^ rnathbatra brother, search for Hitachi Microdrive driver and manually install/ update your flash drive's driver and then it will appear as a fixed disk in disk management.


#5

@ sfarrukh

Thanks a lot bro. Will try it out and post the results here.


#6

Are you using Windows 7 ?


#7

Thanks all

* There is nothing to do with BIOS settings (I believe) in this regard as only this specific Flash Drive appears as a Hard Disk Drive on all ports and on all machines (which I tried). All other Flash drives shows nothing awkward like that.. on the same machines.

* Even BIOS lists this Flash Drive in the Hard Disk Drives.

* Windows 7, Windows XP.. all think it be a Hard Disk Drive.

* But by title, it says "Flash USB Disk" or "USB Flash Disk" (I just forgot)

However it works just fine being a storage device. But reason to fix this issue, is just that it's undetectable where some software reads only from Removable Storage devices.

I believe that the issue is just with this specific device (or some other devices around as has been discussed on the web). It may be driver's issue, or the actual hardware chip?

And didn't get any thing yet which could fix this..

Any other opinions?

@rnathbatra

Didn't manage it. It looks like a manager itself......


#8

--


#9

^ Thanks.. seems logical..

I'll try it, this Monday.. A friend of mine had that Flash Drive from me for some need...


#10

[quote=", post:, topic:"]

It’s a very first experience for me… also just finished searching Google and didn’t find a good help to fix it…

It’s 4GB and is just appearing besides the HDD drives in Hard Disk Drives section. I need it to appear in Removable Storage section.

Any clue?

[/quote]

Would you mind telling the model number and the brand of your flash disk?

[quote=", post:, topic:"]

USBs are blocked at my office but USB Hard Disks are not.

[/quote]

Well thats quite strange group policy itself. You sure USB Hard disks are enabled while USB flash drives are disabled on your PC or on you domain account?


#11

[quote=", post:, topic:"]

^ rnathbatra brother, search for Hitachi Microdrive driver and manually install/ update your flash drive’s driver and then it will appear as a fixed disk in disk management.
[/quote]

Thanks a million bro. It worked like a charm!


#12

@Unlettered

It's promotional drive actually and I couldn't find any original manufacturer identity on it... Just a company's stamp which is promoting its brand.

Also checked from the system properties but couldn't manage to find it..

Is there a way to check the Org. Manufacturer of the drive?

* Or I would need to go for little .NET code to check if that gives some suitable values. But I don't have .NET environment setup on either of the machines right now so I don't want to go long with it only to check the manufacturer unless I really get a solution after finding the manufacturer.

So can you tell me how would we get a fix for it if we knew the manufacturer of the drive?

@rnathbatra

How would you get benefit from the working solution(as sfarrukh suggested). Just wondering that you can't use USB Flash Drives at your office.... so then are you allowed to install softwares and drivers on your own at your office?

Also please let me know if this solution works reversely? I mean if it could also work for me in my situation...

Cheers...


#13

@ Unlettered & KA

I can't disclose much. But the point is that in our company all "removable" storage devices need to be encrypted to work for data transfers. But the encryption process is so slow and painful that no one wants to do that. The USB HDs are the only exception (or a loophole). They work without a glitch since its recognized as a Fixed Drive rather than removable drive by Windows XP, so the encryption prompt does not come up for that. :D. When i installed that driver suggested by sfarrukh and restarted the system, it recognized the USB Drive as a Fixed Drive! So I could read and write data without limitation. This is just for those cases when a large volume of data needs to be transferred on an urgent basis and we don't have a enrcypted device for use.


#14

Btw. Have you tried uninstalling the drivers for the USB? It would be in Device Manager as USB 2.0 etc etc. Just right click that and uninstall it. And then restart the system. And now insert the USB again.


#15

^ That is one of the things I've done, messing within device manage. But It always come up as a fixed HDD.

Just to mention that I've done with the purpose, I had to fix this thing for, using another flash drive any way. And now this topic is just for information only. May be we get such an issue again, so it's good that we'd have the solution already.

edit: still have to test the suggestion by neoclue. will post about the result ASAP


#16

--


#17

[quote=", post:, topic:"]

@Unlettered

It’s promotional drive actually and I couldn’t find any original manufacturer identity on it… Just a company’s stamp which is promoting its brand.

Also checked from the system properties but couldn’t manage to find it…

Is there a way to check the Org. Manufacturer of the drive?

[/quote]

Try Everest or Astra32 you’ll possibly get to know the manufacturer’s identity.

[quote=", post:, topic:"]

So can you tell me how would we get a fix for it if we knew the manufacturer of the drive?

[/quote]

Knowing the manufacturer comes in handy when updating the driver. I am quite positive that updating the driver and editing the registry values would do the trick. Just reverse the method that rnathbatra used.