Unable to fix door lock/unlock via remote in Toyota Corolla XLI 2010

Assalam-o-Alykum;

Dear friends i am now fed up after visiting many times a local electrician to get fixed door lock/unlock feature in my toyota corolla 2010 XLI with remote, as you know XLI version do not have keyless entry feature and one have to install it from local market.

after i got it fixed from a technician it works only for week or so and again it gets stuck and again i have to re-visit technician.

so please help me to fix get this problem fixed permanently.

do i need to change alarm system/remote?

do you know any good and reliable technician how can fix this problem?

looking for your help.

Edit: i am from karachi.

OLX pe bech deeeeeeeeeeeeee.

@askfriends:

Which city are you in ?. It would be helpful if you

would put it into your profile for future reference.

Sheikh 'GPS' Chilli

[quote=“MrKamran, post:2, topic:22178”]

OLX pe bech deeeeeeeeeeeeee.

[/quote]

dont like your non-serious attitude…

[quote=“sheikh_chilli, post:3, topic:22178”]

@askfriends:

Which city are you in ?. It would be helpful if you

would put it into your profile for future reference.

Sheikh ‘GPS’ Chilli

[/quote]

aww…Sorry i would have to mention in the main post, but i am from karachi (North Karachi)

@askfriends:

Can you describe the nature of the problem itself ?.

Does the alarm/door panel make any sounds, or is it

completely dead ?. Does the alarm work, but not the

auto-door-lock ?. Or they are working, but only some

of the doors open/shut with it ?.

If you'd like, I can point you to our techs, who do a

pretty good job of handling all such matters.

Sheikh 'Open & Shut Case' Chilli

[quote=“sheikh_chilli, post:5, topic:22178”]

@askfriends:

Can you describe the nature of the problem itself ?.

Does the alarm/door panel make any sounds, or is it

completely dead ?. Does the alarm work, but not the

auto-door-lock ?. Or they are working, but only some

of the doors open/shut with it ?.

If you’d like, I can point you to our techs, who do a

pretty good job of handling all such matters.

Sheikh ‘Open & Shut Case’ Chilli

[/quote]

thanks for your reply.

alarm does work well, when some buddy try to open the door without unlock it creates sound so no issue there.

the main problem seems to be with door open/shut.

when i press lock/unlcok button on remote it creates sound but door does not un-lock/lock.

when i go to electrician he opened the door and did something like tightening bolt etc and it worked well for a week or so, and again it stuck at same position.

@askfriends:

So you are saying when you press the auto-lock

none of the doors open ?.

I am stressing this because there is a main box,

that triggers individual doors, and then there are

automated latches installed on each door, which

work separately from each other.

If any individual door latch is stuck (busted, or

not well-oiled) you can try to repair or replace

that. If the main panel isn't working, then you

change that.

Sheikh 'Root Cause' Chilli

[quote=“sheikh_chilli, post:7, topic:22178”]

@askfriends:

So you are saying when you press the auto-lock

none of the doors open ?.

I am stressing this because there is a main box,

that triggers individual doors, and then there are

automated latches installed on each door, which

work separately from each other.

If any individual door latch is stuck (busted, or

not well-oiled) you can try to repair or replace

that. If the main panel isn’t working, then you

change that.

Sheikh ‘Root Cause’ Chilli

[/quote]

thanks just got your pm too.

Exactly problem is that what you mentioned, when i press unlock button none of the door opens, and this happens if a single door is stuck so i believe that is the root cause.

how much door latches cost, any idea?

if i replace all 4 latches in 4 doors how much this will cost?

@askfriends:

If none of your doors are opening, then it is very

unlikely that all four of your latches have gone

bad at the same time.

The problem is elsewhere. It could be your control

box, or bad wiring, etc. But you'll know for certain

when an expert on the ground looks at it.

A latch has a few parts. The metal hook that pulls

on the wire inside the door, can sometimes break

off. Other times, the plunger mechanism goes bad

and needs replacing. Last time I had to get one of

them replaced was a couple of years back. I believe

I paid 1-2 hundred. If it's installed right, you can go

trouble-free for years.

Sheikh 'Lock Up' Chilli

Sheikh '

[quote=“sheikh_chilli, post:9, topic:22178”]

@askfriends:

If none of your doors are opening, then it is very

unlikely that all four of your latches have gone

bad at the same time.

The problem is elsewhere. It could be your control

box, or bad wiring, etc. But you’ll know for certain

when an expert on the ground looks at it.

A latch has a few parts. The metal hook that pulls

on the wire inside the door, can sometimes break

off. Other times, the plunger mechanism goes bad

and needs replacing. Last time I had to get one of

them replaced was a couple of years back. I believe

I paid 1-2 hundred. If it’s installed right, you can go

trouble-free for years.

Sheikh ‘Lock Up’ Chilli

Sheikh ’

[/quote]

thank you once again…

Update: Many many thanks to sheikh_chilli for taking interest and time to solve my problem, i visited a shop at tariq road suggested by him and got my car inspected by electrician, after inspection he suggested me to remove the existing wiring and install new wiring and this should solve the problem, so i did, he got new wiring set which about cost 200 or 300 and changed the entire wiring and now i am happy with the result so far..lets see how long it lasts.

@askfriends:

Glad to hear it worked out for you. Let's hope

it stays that way.

Sheikh 'All Locked Up' Chilli