Some websites are not working on PTCL Broadband

well , since last few months. Plenty of websites are not working on PTCL Broadband for me.
i'm not using any proxy or VPN

Like this forum i used to check out dailiy as i'm a travel photography passionate.

http://photography-on-the.net/forum/

and it says COnnection TIme out

bdryvt.jpg

ANy solution?

It open on wingle

[quote=“mfa6464, post:2, topic:21536”]

It open on wingle

[/quote]

cant get a wingle here in my city. is there any solution ?

try using google dns

[quote=“Harry, post:4, topic:21536”]

try using google dns

[/quote]

Already tried. no success

Try open dns

Sent from my GT-I9505

[quote=“masters, post:6, topic:21536”]

Try open dns

Sent from my GT-I9505

[/quote]

tried that as well. didn't work

Tried again and see if site is down or not

Then temporary use vpn. See if it opens there

[quote=“lordjhb22, post:9, topic:21536”]

Then temporary use vpn. See if it opens there

[/quote]

[quote="Capripio, post:8, topic:21536"]

Tried again and see if site is down or not

[/quote]

Yes it opens on VPNs and proxies. But it dont just work without them

And it's not porn website or somthing that they should block .it's a photography forum

Kaoscrew is about torrents and general discussion. It's also unavailable

[quote=“lordjhb22, post:11, topic:21536”]

Kaoscrew is about torrents and general discussion. It's also unavailable

[/quote]

those torrents and porn websits, i have hheard PTCL blocked all of them. But what's the point in blocking a general photography forum... i don't get itt

Extratorrent and piratebay all work fine!

some of my daily visiting sites get blocked al though I am using another connection to open them