RedHat Linux: Samba problem


#1

Hi,

I am using my Red Hat Linux 9 box for samba server.I assigm my linux computer IP 192.168.1.10

and windows machine 192.168.1.20

the workgroup name in windows is workgroup.

In Linux side I do the following configurations.

Code:

# vim /etc/samba/smb.conf

[global]

Workgroup=WORKGROUP

Server string = samba server

Host allow = 192.168.1. 192.168.2.127.

wins support = yes

[shares]

[temp]

comment=Temporary file space

path = /temp

read only = no

public = yes

these are the settings which I have done in smb.conf file.

[root@localhost samba]# service smb restart

[root@localhost samba]# chkconfig --level 35 smb on

Now on windows xp computer when I click on " view workgroup computers " I can see my windows xp and linux computer with name "samba server (localhost).

By double clicking on " samba server (localhost)" windows xp shows a message.

"\\localhost is not accessable.You might not have permission to use this network resource.Contact the sdministrator of this server to find out if you have access permission.

You were not connected because a dublicate name exits on the network.Go to system in control panel to change the computer name and try again"

well I have checked in windows .The computer name is winxp and workgroup is workgroup.

If i write Server string name .i.e samba server in windows explorer as following

\\samba server

it show a message "Windows cannot find '\\samba server'.Check the spell and try again.or try searching for the item by clicking the start button and then clicking search"

Please help me that why i can't even see the dialog box for user name and password. If windows is showing linux machine in workgroup then why it is not showing any diallog box ?

thanks for the help in advance.

garden


#2

look for the net bios name, also if possible look for the firewall permission etc, also make sure u set the passwd using smbpasswd.


#3

@sky

- It's seems that the linux machine has, some how, been named as "localhost". Change the hostname in the linux machine from "localhost" to some thing else which is not already on the network. "localhost" is not supposed to be a name specifically of a machine (if the machine is inside a network). It's rather a reference to the local machine itself. That may be causing windows to conflict with duplicate hostnames. Always try to avoid spaces within a hostname of a computer.

- Try accessing the linux machine with its IP address (e.g. \\192.168.1.10) if the the hostname still not been resolved.

- Try the basic settings first to configure samba server in "smb.conf". Considering a basic set of instructions, do not use firewall settings to allow or deny specific hosts. For that; remove or comment the "Host Allow" command. Also do not use WINS in basic settings.... Set "wins support = no"

- Try making an "smbusers" file and map it in "smb.conf" with setting "security = user". and then add user(s) to "smbusers" file which you want to get authenticated using a Unix account before they access a share.

If you are on Red Hat, try using the Graphical Interface to configure Samba..

Hope it would help..