Please help me setup wireless router with Mobilink Infinity

Dear All. I have been using Mobilink Infinity service for 2 months with no problem. My computer was wired directly in to the Wimax unit. Now I got a Linksys G Wireless Router but I am having trouble setting it up. It says to connect cable from Wimax unit in to Internet jack at rear of router, and then connect ethernet cable from router in to LAN port on laptop. Then power on router and complete setup but it gives error message and says check conncection. Also when Wimax is connected to laptop, the LAN led on the wimax unit lights up but when this is disconnected from the computer and connected in to the router the light does not turn on. Please can anyone who knows what to do help me with this problem. Thank you.

you should change the default gateway entry in your router

it should b

192.168.2.1

i didnt use linksys router ... so i dnt know about it... but i m using siemens speedstream router with mobilink infinity wimax router for wireless connection, and for more wired connections...

the setting for the router is:::

1- "reset" your router to "factory defaults"

2-delete all "atm virtual settings"

3-disable "dynamic dns"

4-disable "rip protocol"

5-ENABLE DHCP ANY SUBNET POOL AND ANY PRIVATE IP RANGE EXCEPT MOBILINK INFINITY LAN IP(DONT USE THIS IP 192.168.2.1 TO 192.168.2.254 OR ANY MOBILINK INFINITY IP)...

6-SETUP YOUR WIRELESS SETTINGS AS YOU WANT...

7-SET "GATEWAY LAN/WAN PORT " TO WAN (THEN CONNECT LAN CABLE FROM MOBILINK INFINITY WIMAX TO WIRELESS ROUTER'S LAN/WAN PORT WHICH IS 4TH LAN PORT ...)

CLICK NEXT,

TICK "BRIDGED IP",

CLICK NEXT,

TICK "USE DHCP"

THEN NEXT

DISABLE ALL ROUTER SECURITIES...

ONLY USE NAPT .... DONT USE NAT OR NAT/NAPT TOGETHER...

FINISH...

SAY THANK WHEN YOU SUCCESSFUL

I WILL TRY TO SOLVE YOUR PROBLEM .... WITH YOUR LNKSYS ROUTER SOON.....