Persistent DNS failure on Maxcom


#1

I have a 2mb Maxcom DSL connection, and after an hour of so running smoothly, the DNS fails to resolve, which stops all browsing. The modem stays connected, and the internet works as well, just that DNS doesn't work.

I get around this by entering google's public DNS servers in my pc, but whenever someone comes over the internet doesn't work as they need to enter the settings manually, which is really annoying. Maxcom seems unable to to comprehend this as an issue... so I was wondering if anyone knows what the problem could be and how to fix it?

The other issue is Google's dns servers are quite far away, so I'm assuming they're slower than Maxcom's own - heres the traceroute for the google dns:


traceroute to 8.8.4.4 (8.8.4.4), 64 hops max, 52 byte packets
1 192.168.50.1 (192.168.50.1) 6.327 ms 3.349 ms 2.236 ms
2 1.109.181.58.dynamic.max.com.pk (58.181.109.1) 12.624 ms 9.648 ms 9.802 ms
3 192.168.1.18 (192.168.1.18) 10.975 ms 14.003 ms 24.897 ms
4 192.168.3.5 (192.168.3.5) 18.176 ms 15.744 ms 39.417 ms
5 khi77.pie.net.pk (202.125.137.49) 12.707 ms 29.916 ms 13.284 ms
6 221.120.251.9 (221.120.251.9) 19.775 ms 31.005 ms 14.508 ms
7 static-khi-ni02-swa.pie.net.pk (202.125.128.180) 14.036 ms 26.946 ms 20.360 ms
8 74.125.49.9 (74.125.49.9) 82.705 ms 84.828 ms 82.998 ms
9 209.85.254.166 (209.85.254.166) 82.991 ms 112.022 ms 84.015 ms
10 209.85.242.233 (209.85.242.233) 122.162 ms 89.512 ms 89.453 ms
11 209.85.241.173 (209.85.241.173) 98.088 ms
209.85.242.125 (209.85.242.125) 116.851 ms
209.85.241.173 (209.85.241.173) 95.544 ms
12 209.85.243.146 (209.85.243.146) 102.947 ms
209.85.250.58 (209.85.250.58) 105.194 ms
209.85.243.142 (209.85.243.142) 92.680 ms
13 74.125.206.22 (74.125.206.22) 139.040 ms
74.125.206.26 (74.125.206.26) 98.662 ms
74.125.206.10 (74.125.206.10) 97.808 ms
14 google-public-dns-b.google.com (8.8.4.4) 132.957 ms 97.442 ms 95.451 ms ```

Some further info below:

The Maxcom DSL modem is functioning as a router, and automatically assigns it’s own IP address to all client PCs. When I connect my laptop using a working ethernet cable directly to the modem it assigns a dns, ip etc. through DHCP. The default DNS assigned is the ip address of the router, which acts as the local dns server passing on requests to the upstream maxcom server. Below I have put in the output from a lookup for google.com. Now when I replace the DNS servers on my laptop with any publicly usable ones like opendns or googles public dns than everything works just fine.

```
Lookup has started…


; <> DiG 9.6.0-APPLE-P2 <> google.com +multiline +nocomments +nocmd +noquestion +nostats +search
;; global options: +cmd
;; connection timed out; no servers could be reached

#2

Does your router not have options for specifying which primary and secondary DNS servers to use under WAN settings?


#3

It does, but the default dns it assigns is always itself. So the modem fails to pass on the dns request onwards to whatever dns server I put in its settings.


#4

Do you have these values under your TCP/IP Property

dialog box ?.

Subnet mask: 255.0.0.0

Default Gateway: 10.0.0.138

Preferred DNS Server: 202.70.150.10

Alternate DNS Server: 202.70.150.11

Click the "Advanced" tab and click on DNS

===============================

These should be checked in DNS tab:

01. Append primary and connection specific DNS suffixes

02. Append parent suffixes of the primary DNS suffix

03. Register this connection's addresses in DNS

These should be checked in the WINS tab:

01. Enable LMHOSTS lookup

02. NetBIOS setting (default)

These should be checked in the IP Settings:

01. Automatic metric

.

.

.

Sheikh 'Allah Sain Madad Karey Ga' Chilli