Network Settings with multiple WiFi Routers - Review Required

The problem is to maintain one specific IP address on a computer's Wireless Adapter, which often connects with 3 different Wireless Routers (on same IP range 192.168.1.x). The settings are working without any problem. yet the problem is there, I would ask below after detailing the scenario I am having.

There are 3 routers which I use to connect with all the day. Actually 2 routers and one Wateen's Device with built-in WiFi access point which are 3 in total.

- Say "W1" being Wateen Device with wireless AP is having the device local IP address as "192.168.1.1", and so is added in my laptop as a gateway (shown below in IP Setting image)

- And "R1" being Router-1 is connected externally to Worldcall media converter. "R1" is set with "192.168.1.254" as its local IP address, and also is added in my laptop as a gateway (shown below in IP Setting image)

- Now "R2" being Router-2 is connected again to another Wateen's device. "R2" is also set to have local IP address "192.168.254", which is already in the IP setting on the laptop as shown below...

You may question that why didn't I also set "W1" with the same IP as other two are.. I tried actually but I think, the device called "blade" don't remember its model now, didn't let me set the device with the IP as "192.168.1.254". It seems to be poor validations on the form. On the other hand I don't want to change the IPs on other routers.. That's why I had to put both of the gateways in my laptop's IP settings.

So when specifying IP addresses manually I would also need to specify the DNS addresses to use with the connections. I did as appeared shown below in other image with "DNS" tab opened. I just added two DNS addresses to work when connected with Wateen and other two DNS addresses to work when connected to Worldcall.

35817623.jpgdnsu.jpg

::: Problem :::

The settings are just good and working fine on the Laptop. What I need to do is just to re-connect at bottom right corner with one of the Three WiFi profiles (created for each WiFi Router/AP). But the issue is the "Resolution of the addresses" depending on the priority in which the DNS are ordered above. As it works in order when you try to access a host or website so with these settings if I try to access a simple website when connected to Worldcall, it takes time to resolve the website URL. Of course it would take time as it has to lookup in specified order. So it would also cause the same problem when connected to Wateen if the Wateen's DNS addresses are placed later.

The question is.... Is there any thing to do to have it working smoothly just like it works with individual settings for each connection.?

Wow this is complicated.. i am unable to set one wifi router here at my place.

Solutions:

1. If you can make the gateway same for all routers/access points, then you can simply put the gateway IP, as a DNS address.

2. Why not simply use automatic settings ? Let the routers DHCP server assign your wireless adapter an IP address, and automatically tell it the DNS servers.

3. There must be some software, which allows to set specific DNS addresses for each profile

I think you should use opendns for both connections and this http://wifihopper.com/features.html might also be helpful.

[quote=", post:, topic:"]

1. If you can make the gateway same for all routers/access points, then you can simply put the gateway IP, as a DNS address.
[/quote]

- Would really the gateway work if specified in in DNS list? I would try that any way with two of the routers to test but can’t with third one having gateway at 192.168.1.1, see below.

- I already mentioned in OP

[quote=", post:, topic:"]
You may question that why didn’t I also set “W1” with the same IP as other two are… I tried actually but I think, the device called “blade” don’t remember its model now, didn’t let me set the device with the IP as “192.168.1.254”. It seems to be poor validations on the form. On the other hand I don’t want to change the IPs on other routers… That’s why I had to put both of the gateways in my laptop’s IP settings.
[/quote]

I tried in “Wateen’s device with WiFi” to set also with 192.168.1.254. but it’s some thing like stupid, it didn’t let me use this specific IP and prompted me with “Invalid IP address”. It also doesn’t let me choose an IP for the device which comes later than the lease starting IP address.

[quote=", post:, topic:"]
2. Why not simply use automatic settings ? Let the routers DHCP server assign your wireless adapter an IP address, and automatically tell it the DNS servers.
[/quote]

I also stated that “The problem is to maintain one specific IP address on a computer’s Wireless Adapter”. That’s why I actually needed this setup, other wise it was fine with DHCP assigned addresses…

However, I actually have a set of server applications installed and running on the laptop which remain in use, very usually, at each site. And they all have been configured on one IP address, where you would say that is not reliable to have an automatic setup… I actually have same IP address set even on the Ethernet adapter :P when ever I got to use it some where I just disable the wireless adapter and enable it…

[quote=", post:, topic:"]
3. There must be some software, which allows to set specific DNS addresses for each profile
[/quote]

Yes! this is some thing like a solution… but which software? any one knows about such a software???

[quote=", post:, topic:"]

I think you should use opendns for both connections and this http://wifihopper.com/features.html might also be helpful.
[/quote]

Oh you actually have referred to such a software. Right? I just downloaded it and yet to install but DAP flagged a security risk with downloaded file due to ClamWin(one of the Antivirus Softwares at DAP server) detected “Trojan.Agent-21984”. AVG at my end didn’t reported any thing…

Anyways, I would try that software and would write about that soon.

About OpenDNS, is that I can’t use it or any alike service in office. it’s restricted…

Sorry! It gave error during the installation about unsupported version of Windows. I am using Windows 7. any how re-continued with using Windows XP compatibility mode and it did install. but I think it is still not willing to work on Windows 7. The software isn't able to detect the network adapters on the system.....

Just emailed them at their support. I would see if they reply positively..

Thank you guys... I appreciate your help. Please update if any thing more you get about it.... I

[quote=", post:, topic:"]

I also stated that “The problem is to maintain one specific IP address on a computer’s Wireless Adapter”. That’s why I actually needed this setup, other wise it was fine with DHCP assigned addresses…

[/quote]

Well you can configure the DHCP servers in routers, for static lease. That will always assign a specific IP address to networking adapter checking its MAC address.

I also static leases, using DD-WRT, and most of the routers have this option

captureqd.png

^ This would be even better option if I could be able to do it with all of the devices but I gotta deal with the following devices.

W1 => The Motorola CPEi 35775 (aka blade) with WiFi

Which I doubt that I could set it with static lease with stock firmware. Plus I doubt that I could update it with any third party or custom firmware according to my desires. Plus the doubt still remains that it could give static leases even on any third party firmwares....

R1 => Linksys WRT54G2

I never updated tried a third party firmware like DD-WRT on it or on any other router. I think I would need to give it a try.... Any working references for installing dd-wrt would be appreciated... Thanks

R2 => CISCO PIX 501 - Firewall

I would look into it. I hope there would be a pre-built function for the purpose, not sure though...

Thanks for your input...

^ for installing DD-WRT, follow these simple steps given on this site DD - WRT wiki

^ Thanks; I just have finished installing DD-WRT using the referenced page on the Linksys Router. (wiki's nicely detailed, thanks to the dd-wrt as well)

In addition I just have found that the Wateen's device does allow to reserve IP addresses specified by client MACs....... So I'll look into the PIX firewall tomorrow..

You are welcome. With DD-wrt on your routers I don't think you will need anything else. It just like having a mini-linux on you router. I think your job is done now.

^Yes! but it's also not that which I've heard about it. This is only first time I used DD-WRT. There are still limited policies slots given for Access Restrictions on the web interface, which I thought would be able to add as many as I want.

I didn't explore it as much yet but in addition to above limited access, the SSHd option isn't available in the latest build I upgraded to, after downloading from http://www.dd-wrt.com/site/support/router-database for WRT54G2 v1.0. The option was also not available in the build I installed initially via the TFTP.. After reading about that on the forums I didn't find any good reference for this issue but only the same issues have been raised in a lot and the problem is said to be the "micro" build that it doesn't have SSHd option in it. But there was still not any solution to this posted any where that even after having another build would solve the problem or not...

Second, I am also having problem enabling Remote Access (from WAN) to its web interface even though it's turned on. The solution to which is also not found on the forums but some of the questions regarding it unanswered. And having remote access is also one of the primary requirements of mine, I have had access remotely to the router with the stock firmware... So hoping that to have it fixed ASAP....... Of course it's on a Static IP from ISP......

and about........ the job is done or not....

Not actually.....

I am not a Cisco Expert at all.... even than I have configured PIX-501 in different ways my self which is not so much of experts tasks. But specially for this job, I have searched through the interface of the PIX-501 and didn't find any clue that I could be able to configure it with a pre-defined reserved IP Leases. It may or may not have support for it....

So about the Job.... I can say that it's not completely done....

about the remote access thing....

1. Are you opening the web interface like,

 http://your.routers.ip/ ? 
  • Open your routers web interface with port specified i.e.
     http://your.routers.ip:port e.g. http://119.xxx.xxx.xxx:8080 

    2. Are you behind a proxy, that only allows to open webpages on port 80 ?

    - This situation is common at work places, the workaround to it, is to change web access port from DD-WRT’s interface to 80

^ Yep! that's all I've tried but there seemed to be no gain.. on any of the ports...

As as I said I have Static IP on the concerned router. and It's all open to the WAN there is no proxy involved. but it was configured on my end with all of the security like blocking access from WAN on all ports and left some specific ones open for specific needs.

works like a charm for me, I have dyndns enabled, and Web GUI port set to 80

Which version of dd wrt, you have installed ? All three of them are listed as beta. SSH is isn't listed in micro http://en.wikipedia.org/wiki/DD-WRT#Features

@omernaeem17 which router are you using ? Also doesn't the mega version works on WRT54G2 v1.0

Edit: Can you suggest a broadcom based cheap router available in Pakistan

[quote=", post:, topic:"]

I also stated that “The problem is to maintain one specific IP address on a computer’s Wireless Adapter”.

[/quote]

You can bind your computer’s mac id to a specific IP address in all the routers and enable DHCP. That way your computer will always get the same IP address assigned to it by DHCP.

As far as DNS lookups slowing down are concerned you can use opendns or google dns instead of ISP specific nameservers.

You can also look for some freeware caching dns server:

http://www.ntcanuck.com/index.htm

^ Good to see you in the discussion... and thanks for your comment...

You perhaps suggested about "Reserved/Static IP Leases". we actually have done with it you might want to read the other posts in the thread to find about where I am stuck at.... I hope you would give a look at it...

I also have answered on OpenDNS why I can't use it for a workaround...

I do have already set it up at home with some restrictions you know on Home PC. but I always use the Wateen's one specifically on my machine... So I would prefer any workaround but other than involving the third party DNS.

KA you really should install treewalk dns which I linked to above. Its not ideal but it will allow you to maintain a local DNS cache and free you from dependency on ISP specific servers.