Messenger lags alot on ptcl 4MB. please help


#1

guys. using messengers like LIve and yahoo messengers, it lags like hell.

i never receive msgs while chating, and after some mintures, i gets those many messages alltogether.

Did one thing. turnd off my Wireless router, Plugged in Ethernet cable, Tried bridging in Adsl modem, then connected manually (like we used to connect the dialup)

It worked perfectly fine

no lagging at all.

no connection time outs.

But , Actually via this way, i hav to connect each time, and I am using TP link router and using internet on more then 3 PC's so it wont work on multiple pc's

So guys. whats the solution.


#2

use Pidgin


#3

But its not due to Messenger man, its due to Connection's inactivity.

How comes it works with bridging connection but not via normal way


#4

1. did ya change the MTU ??? if you changed the MTU to 1500 or 1436 or any other, change it back to 1492.

2. There might be a connection limit on your router, when I installed DD-WRT on my linksys wrt54g2 it had connection limit of 512 connections, which was creating a bottleneck, increasing to 2048 uses more RAM(of router) but solved the issue.

3. To free routers ram, to make it run fast, close/disable any extra services running in your router that you don't need. e.g. DMZ, UPnP, QoS scheduler, Time client, DDNS, Telnet, any logger/traffic counter.

If you are comfortable with telnet then disabling routers web interface, will save significant memory.

4. Make sure that only one DHCP server is running. If modem is making the PPPoE connection then let the DHCP server on modem run, and disable DHCP on TP link router, if modem is in bridge mode and TP link router is making the PPPoE connection then let the DHCP server run in TP Link router and disable it in the modem