Login Failure Issue Workarrounds (if happens to you)

Extending from the thread http://www.wiredpakistan.com/forums/viewtopic.php?id=7108

after searching the google I found that the same issue has been discussed on PunBB's and FluxBB's boards after the later upgrades. but there is no solution found to be fixed on the Forums or servers. but after combining the results I managed to find some workaround.

I found the following thread where a FluxBB developer is suggesting to remove the files from the FluxBB's Cache folder.

http://fluxbb.org/forums/topic/1348/you-appear-to-have-logged-in-successfully-however-a-cookie-has-not-be/

it would be great if there is no problem to remove cache files from your server. may be it is causing the problem to several users. but only if you find it ok with you.

on the other hand I have found that the problem is with Updated DST rules differences that are on the server and the ones on the client.

FluxBB has been updated within the script to implement the new rules

and whatsoever the 1-hour increment in time in Pakistan is not actually by DST rules. as you know that our government planned to reduce the consumption of the electricity so they started to increase and decrease the time by 1-hour.

that is actually causing the differences.

here is how I tested

as you know (for both administrators and members)

Ekaterinburg, and Islamabad both are GMT+0500 but the difference is that according to the new DST rules Ekaterinburg has the option to adjust the clock for daylight savings changes. but not Islamabad.

so

1-when I update my system clock with Time Zone of (GMT+0500-Islamabad) ,the system sets the time as it would be without so-called 1-hour increment.

having these settings, then if you try to login on WP. it goes fine without any problem. but in this way system clock is one hour behind the actual current PST.

2-but of course If I need the current time as of PST to be set on my machines. then I manually have to update the system time with 1-hour added. because there is no option for day light savings in Pakstan.

here comes the problem. if I do so and go with this change, it miss-matches the DST rules on the server.

also consider the option in Windows XP System Clock in the Tab Internet Time. "Automatically synchronize with an internet time server" if this check box is turned on then the system frequently sync the system time with the server selected according to the latest updated DST Rules. and that means if you set your time manually with 1-hour added after some time it will automatically be reset to the actual GMT+0500. this can be identified as if you set your time with 1-hour added and come to log in to WP and you face the error after some time or after your system reboot you suddenly notice that you again can login. that is because of your system time that has been reset to with subtracting 1 hour. that is less than 1 hour from current PST. if you want to remain on 1-hour added in time then you have to turned off the "Automatically sync option"

being on manually 1 hour addition actually causes the Login Failure.

why? look at below

suppose my system clock is set to GMT+0500 and manually added 1-hour to the time.

then I request for login on the server. then two things are independently used to be matched with the server times, they are "Time Zone and DST" and the "Actual Time of client machine" Sent.

as I have just tested with the FluxBB configuration on my server it gives the option for DST for all the Time Zones. that on my request Asad probably have set to GMT+0500 and NOW DST Turned ON. Turning On the DST was actually the option that was to be turned ON, He did right. but after searching a lot I found that this DST doesn't actually happens in real because Day Light Savings for Pakistan is not added in the DST Rules. thats why the problem happens.

continuing the above login request, the server matches the request with the GMT+0500 and adds the 1-hour as for DST settings turned ON on the Forums, when it adds 1-hour than automatically the "Vist Timout"=10 min set in Forums' configuration turns true in execution and returns the error.

Yes! increasing Visit Timout up to atleast 1.5-hours on the Forums also over come the issue but there is big security risk for users. they will mostly remain signedin if forget to logoff and if any one other visit the Forums on the same computer the he will automatically be signed-in. so this is good enough to forget about increasing the Visit Timeout.

but I think if another change in the "CHANGE that Asad has made on my request earlier" that is to set "GMT+0600 with DST Turned OFF" instead of "GMT+0500 with DST Turned ON". that probably will also fix the issue.

And If there is no way to update any settings or to remove cache files on the Forums/server(also it's not what I tested. just got on the FluxBB's board). I know there could be many reasons for that. making these kind of changes on servers takes time and there is a risk of things to be messed up specifically the changes with Time or Time Zones.

So I prefer it for the members(who have the issue and want to have workaround for it) they have to update their system clock as below if they are not able to login with facing the concerned issue.

================================================

ON THE CLIENT MACHINE===========================

================================================

If DST option available with GMT+0500(see all GMT+0500 options) then make changes in the clock settings as the 1st option below

If DST option is not available with GMT+0500 then make changes in the clock settings as the 2nd option

1st option: GMT+0500 and DST Turned ON

2nd option: GMT+0600 and DST Turned OFF.

and if the user is not wishing to update with it(like one could wish to live with our very own GMT+0500, Islamabad). then he should leave the time on older PST time without 1 hour added.

but do not use

3rd option: GMT+0500 and manual 1 hour added to the time.

================================================

I hope it will help members who have faced the issue or not yet familier with that

I've been using the 2nd option

I was using 3rd option, changed to 2nd option now. thanks

off topic:

very nice siggy osmanzubair :D