Homage UPS problem

Hello guys My Homage UPS has just shown a strange problem i.e It is on and giving backup but If I connect it to main-power it remains in backup mode I tried to change main power cable but problem remain , What is wrong with it ? Is It anything to do with relay? Can I change it myself or I have to contact service center???

Thanks for your help

Is it in warranty? If so, contact the service center.

You should try the following if your UPS is OUT OF WARRANTY.

If you are lucky, then probably the input fuse is blown. On the backside of UPS, there should be a AC input socket where you connect the Wapda input voltage. If you have a similar socket, there is a fuse inside the socket, you can open it like this

0717-1pw.jpg

Before trying to access the fuse, disconnect AC input, disconnect battery and load, wait 5 minutes and then access the fuse holder tray using a small flat screw driver.

[quote=", post:3, topic:21431"]

You should try the following if your UPS is OUT OF WARRANTY.

If you are lucky, then probably the input fuse is blown. On the backside of UPS, there should be a AC input socket where you connect the Wapda input voltage. If you have a similar socket, there is a fuse inside the socket, you can open it like this

0717-1pw.jpg

Before trying to access the fuse, disconnect AC input, disconnect battery and load, wait 5 minutes and then access the fuse holder tray using a small flat screw driver.

[/quote]

Many thanks let me check it my Homage is similar to this one it seems it has fuse inside.....

IMG_0791.jpg

[quote="Asad, post:2, topic:21431"]

Is it in warranty? If so, contact the service center.

[/quote]

No it is not in warranty

[quote=", post:3, topic:21431"]

You should try the following if your UPS is OUT OF WARRANTY.

If you are lucky, then probably the input fuse is blown. On the backside of UPS, there should be a AC input socket where you connect the Wapda input voltage. If you have a similar socket, there is a fuse inside the socket, you can open it like this

[/quote]

WOW, You just saved my all of my hassle which involes 7 days delay at homage service center , insulting attitude of staff and ghost service + parts charges Love you man :)

Yes the fuse was blown I replaced it and now it is working fine the cost was just 5 Rupees. :)

There is one confusion though i.e The orignal fuse has marking "T6.3A 250V" and the new fuse has marking "P3.1A 250V" are these same ? The shopkeeper told me it is 3A fuse not 6.3A

[quote=“jamalkhan, post:5, topic:21431”]

WOW, You just saved my all of my hassle which involes 7 days delay at homage service center , insulting attitude of staff and ghost service + parts charges Love you man :)

Yes the fuse was blown I replaced it and now it is working fine the cost was just 5 Rupees. :)

There is one confusion though i.e The orignal fuse has marking "T6.3A 250V" and the new fuse has marking "P3.1A 250V" are these same ? The shopkeeper told me it is 3A fuse not 6.3A

[/quote]

No, you should have replaced it with a 250V 6.3A fuse.

Use fuse of similar rating to one you removed from fuse holder.

[quote=“yousaf465, post:6, topic:21431”]

No, you should have replaced it with a 250V 6.3A fuse.

[/quote]

[quote="Asad, post:7, topic:21431"]

Use fuse of similar rating to one you removed from fuse holder.

[/quote]

Thanks guys... See how corrupt our enviroment has become, Just to earn five rupees the shopkeeper lied to me .. What a shame.... not for a single moment he thought what damage it could cuase ....

[quote=“jamalkhan, post:5, topic:21431”]

There is one confusion though i.e The orignal fuse has marking "T6.3A 250V" and the new fuse has marking "P3.1A 250V" are these same ? The shopkeeper told me it is 3A fuse not 6.3A

[/quote]

Good to know that your problem got solved. As my fellow memebers already explained, you will need a 6A or 5A fuse. Never go for 10A or 15A even if someone gives you for free.

This 3.1A will keep working, as such lower rating is not hazardous but it will soon blow if you turn on many loads which are on UPS, or if your battery is deeply discharged then this fuse may again blow.

Get 6A or 5A and keep few of them as spare.

BTW in many IEC sockets, the plastic tray where this fuse is inserte, have a place for a spare fuse as well.

[quote=", post:9, topic:21431"]

Good to know that your problem got solved. As my fellow memebers already explained, you will need a 6A or 5A fuse. Never go for 10A or 15A even if someone gives you for free.

This 3.1A will keep working, as such lower rating is not hazardous but it will soon blow if you turn on many loads which are on UPS, or if your battery is deeply discharged then this fuse may again blow.

Get 6A or 5A and keep few of them as spare.

BTW in many IEC sockets, the plastic tray where this fuse is inserte, have a place for a spare fuse as well.

[/quote]

Yes I have replaced it now with 6A (P6AL 250v) exact rating fuse was not avaliable

But another problem has just arise UPS backup has suddenly dropped from 6 hour to 1 hour (I'm surprised Is it even possible)

Actually this all started yesterday when first my ceiling fan burnt and gave smoke then this fuse thing happened, Though everything seems back to normal after replacing the fuse but I donot know what happened to battery just a day before yesterday it was giving a 6 hour backup ,Does that sudden burning of FAN did something to battery???

[quote=“jamalkhan, post:10, topic:21431”]

Actually this all started yesterday when first my ceiling fan burnt and gave smoke then this fuse thing happened, Though everything seems back to normal after replacing the fuse but I donot know what happened to battery just a day before yesterday it was giving a 6 hour backup ,Does that sudden burning of FAN did something to battery???

[/quote]

From 6 hours backup, I assume you have a big battery.

When this fuse blew up, charging was stopped and your loads were running on battery. How long this lasted ? I think your battery has drained considerably during this time (from fuse blow to fuse replacement).

If load shedding is frequent, the solution is to turn off the loads and let the UPS charge the battery for 12-14 hours.

A burnt fuse can't damage the battery. However there is a little possibility that your charger (inside UPS) is not properly functioning now.

[quote=", post:11, topic:21431"]

From 6 hours backup, I assume you have a big battery.

When this fuse blew up, charging was stopped and your loads were running on battery. How long this lasted ? I think your battery has drained considerably during this time (from fuse blow to fuse replacement).

If load shedding is frequent, the solution is to turn off the loads and let the UPS charge the battery for 12-14 hours.

A burnt fuse can't damage the battery. However there is a little possibility that your charger (inside UPS) is not properly functioning now.

[/quote]

I think I'm in huge mess now ,After replacing fuse I let it on charging for last 24 hours (without using any backup) but it is still showing "Charging in progress" and battery is heated up like hell .......... After 24 hours of charging the backup remain at 1 hour limit or probably few minute less than yesterday ....THat means backup is dropping

THe battery is AGS 165 AMP and this is third season of its service .........

One thing is clear I have to take UPS to service center but do I have to change my battery now ??? Or an overhall would be good enough?

Disconnect the battery to avoid further overcharging. Most probably some internal problem also happened but that has got nothing to do with changing the fuse.

What is your location ? If you are in Lahore, some guys service these UPS at Hall Road. They may save you time.

[quote=", post:13, topic:21431"]

Disconnect the battery to avoid further overcharging. Most probably some internal problem also happened but that has got nothing to do with changing the fuse.

What is your location ? If you are in Lahore, some guys service these UPS at Hall Road. They may save you time.

[/quote]

I'm in new Muslim town,Lahore , can you please provide me the shop contact if you have coz in this hot & humid season I can't afford to wait 7 days at homage service center ,

BY the way what damage this overcharging brings to battery???

[quote=“jamalkhan, post:14, topic:21431”]

I'm in new Muslim town,Lahore , can you please provide me the shop contact if you have coz in this hot & humid season I can't afford to wait 7 days at homage service center ,

BY the way what damage this overcharging brings to battery???

[/quote]

check the water level, and replace it AGS water.

Bottle has proper seal.

[quote=“jamalkhan, post:14, topic:21431”]

I'm in new Muslim town,Lahore , can you please provide me the shop contact if you have coz in this hot & humid season I can't afford to wait 7 days at homage service center ,

BY the way what damage this overcharging brings to battery???

[/quote]

Since I am not based in Lahore so can't give you a contact. You need to go to Hall Road and ask there.

May be Farhan_DS can tell you any place in Lahore since he is from Lahore.

[quote=", post:16, topic:21431"]

Since I am not based in Lahore so can't give you a contact. You need to go to Hall Road and ask there.

May be Farhan_DS can tell you any place in Lahore since he is from Lahore.

[/quote]

Its alright the way you asked I thought you know the contacts ,Hall road has hundereds of electronics shops and dozens of repair shops and just Going there and asking random people for such service guys is not a good idea coz most probably you will land at some inexperienced technician shop.

I would prefer to go Homage service center in this case .....

[quote=“jamalkhan, post:17, topic:21431”]

Its alright the way you asked I thought you know the contacts ,Hall road has hundereds of electronics shops and dozens of repair shops and just Going there and asking arbitary people for such service guys is not a good idea coz most probably you will land at some inexperienced technician shop.

I would prefer to go Homage service center in this case …

[/quote]

Do you know any reliable UPS shop on Wadahat road ?

[quote=“yousaf465, post:18, topic:21431”]

Do you know any reliable UPS shop on Wadahat road ?

[/quote]

No I don't .... I actually don't know any reliable UPS shop in entire Lahore :) THat is why I think Homage servic center is better even though one has to wait for 7 days.....

I have homage hmx2001-1400 watts with 2*165 ags batteries installed on july,2013.from last 2 days after 1 hour of load shedding it keeps fast charging for many hours & only stops when I turn it off/on.batteries volts are 13.60&13.90.battery with 13.90 has some white deposits on +ve terminal.what is causing this problem?I think there is lot of dust accumulated inside which needs to be cleaned with blower.i phoned homage service center they told batteries need to be checked for gravity as may be some cells are dead.please give suggestions.

Sent from my Z10 using Tapatalk