File sharing not working


#1

Guys i've a couple of pc's at my home which i've networked through crossover cable. Earlier file sharing was working ok but now it's not working and an error comes that

Computer is not accessible u might not have permission to use this ntwk resource contact admin. Access denied

Microsoft file sharing is installed on both pc's and ping for both is also working net connection sharing is also working just the file sharing is not working.

Is there any solution to it? Both pc's have static ip's


#2

make sure the workgroup of both pc is same


#3

Workgroup is also same.


#4

disable firewall in the pc you are trying to connect

firewall include windows firewall!


#5

all the firewalls at both pc's are disabled.


#6

Did you install SP3 on the computer which is not accessible?

My home network is facing a similar problem and remote connection nor the normal LAN is functional on the one PC which was manually upgraded to SP3.


#7

[quote=", post:, topic:"]

all the firewalls at both pc’s are disabled.
[/quote]

disable file sharing and enable again


#8

i dint install sp3. And i've disabled and enabled the file sharing already but to no avail. And both the pc's are facing similar problems means no pc can access the shared files from other.


#9

[quote=", post:, topic:"]

Did you install SP3 on the computer which is not accessible?

My home network is facing a similar problem and remote connection nor the normal LAN is functional on the one PC which was manually upgraded to SP3.

[/quote]

Do you recommend upgrading to XP SP3? Kindly write the most prominent changes that can be seen.


#10

there are no big changes in SP3 its just the previous updates that have been integrated into XP AFAIK


#11

^^ Yes. However, do a clean install via a slipstreamed media instead of upgrading from SP2 to SP3 via the standalone upgrade file.

^ There have been some changes under the body. I don't know the details but it has something to do with networking.


#12

check your router, sometimes you have to open up the tcp and udp ports on router which your p2p is using


#13

How exactly are u trying to access the shared files ? Via the network shorutcuts in xp ? Try using this method.. first ping the ip address of ur destination pc to be sure its up. then go to run type command and then type start \\192.168.x.x where 192.168.x.x is ur desitnation ip. This should open the share directories of the computer. Alternatively you can type \\192.168.x.x in run to chk if u can access the shared files on the pc. If this doesnt work then u shld try reseting ur switch/router.


#14

I'm not able to access the files on other computer in any way i've tried the

\\computer-name \\ipadd

But no success earlier it used to work fine but don't know why it's not working

I think It's some issue due to router settings


#15

ok so you are behind a router!

are pings working?


#16

yup i already told u that both pc's can ping eachother. And i'm talking about dsl router.

And the pc's are connected through crossover cable.

Actuall the problem is that the pc through which i use the dsl prhibits me for using file sharing.

I've 2 cpu's, earlier i was using dsl router on 1st cpu then files shared by this 1st cpu weren't accessible on 2nd cpu but files shared by 2nd cpu were accessible on 1st, but now as i connected my 2nd cpu to dsl router now both pc's can't access shared files.

Sorry if it's confusing


#17

[quote=", post:, topic:"]

yup i already told u that both pc’s can ping eachother. And i’m talking about dsl router.

And the pc’s are connected through crossover cable.

Actuall the problem is that the pc through which i use the dsl prhibits me for using file sharing.

I’ve 2 cpu’s, earlier i was using dsl router on 1st cpu then files shared by this 1st cpu weren’t accessible on 2nd cpu but files shared by 2nd cpu were accessible on 1st, but now as i connected my 2nd cpu to dsl router now both pc’s can’t access shared files.

Sorry if it’s confusing

[/quote]

both PC’s gateway IP are same?


#18

You might have enabled the "user isolation" option available in router, disable it


#19

gateway ip???

And where is the user isolation option in router setting


#20

i think i know whats wrong,

let me tell u what i understand.

you have pc1 and pc2,

you can ping pc1 from pc2

you can ping pc2 from pc1

you can open files on pc1 shared on pc2

problem you can open files shared on pc1 is that right?

then try right click on network connections and property of ur network connection and make sure file and printer sharing checkbox is ticked, try this and let me know