Check disk

I have a question that my computer is scanning H drive each time of booting and its just annoying. Could you people tell me that why is this happening and whats the solution to stop? I always shut down my computer properly and by the way H drive is for uninstalled software setups. Thanks

Regards,

change its file system frm FAT32 to NTFS

then it wont

if u want comands for changing file system kindly GOOGLE it.....

[quote=", post:, topic:"]

I have a question that my computer is scanning H drive each time of booting and its just annoying. Could you people tell me that why is this happening and whats the solution to stop? I always shut down my computer properly and by the way H drive is for uninstalled software setups. Thanks

Regards,

[/quote]

Here are some things you can try. Let it run completely once.

Run regedit

Edit: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Session Manager

Change the BootExecute entry from:

autocheck autochk * /.

To:

autocheck autochk *

Or else try this :

Start> Run> bring up a command prompt by typing in “CMD” and type " fsutil dirty query g: ". This queries the drive, and more than likely it will tell you that it is dirty. Next, type “CHKNTFS /X G:”. The X tells Windows to NOT check that particular drive (G) on the next reboot. At this time, manually reboot your computer, it should not do a Chkdsk and take you directly to Windows.

Once Windows has fully loaded, bring up another CMD prompt and type and now you want to do a Chkdsk manually by typing “Chkdsk /f /r g:”. This should take you through 5 stages of the scan and will unset that dirty bit. Finally, type “fsutil dirty query g:” and Windows will confirm that the dirty bit is not set on that drive.

I had the same problem before…I used the second option.

Hope that helps!

Changing the drive format will probably help you. Go in cmd type in the following command wihtout quotation mark

"convert X: /fs:ntfs" (where X is the name o fdrive letter)

this commcand will not lose your data. If you are trying to convert the drive on which operating system is installed then it will convert on next system restart.

[quote=", post:, topic:"]

I have a question that my computer is scanning H drive each time of booting and its just annoying. Could you people tell me that why is this happening and whats the solution to stop? I always shut down my computer properly
[/quote]

At booting, AutoChk automatically scan for partitions that marked “dirty”. There are solutions, as mentioned in this thread, to forcefully stop AutoChk from scanning that said partition H:. But it is not a good solution. You need to find out why Windows is flagging it dirty? Do a complete scan (all 5 steps scan) with scanning for bad sectors.

By the way, which format your partition has? NTFS or FAT32? NTFS is better than FAT32 in most cases.

[quote=", post:, topic:"]
by the way H drive is for uninstalled software setups.
[/quote]

What are “Uninstalled Software Setups”? :rolleyes:

I have FAT32 right now. I scanned my HDD with scandisk command too but it doesn't found anything dirty. I will try to change the file system.

[quote=", post:, topic:"]

I have FAT32 right now. I scanned my HDD with scandisk command too but it doesn’t found anything dirty. I will try to change the file system.
[/quote]

Just to clear, are you using Windows XP? If so then changing format to NTFS might help.

By the way, if problem persist then copy data to any other partition. Delete partition H:, create new partition for H: and format with “full” (not quick) format. Then copy back data to H: partition.

Yes i am using Windows XP. Well, the H drive is already on NTFS system. This is windows drive which is on FAT32. This wasn't happened to me before, this is the first happening to me.

Well, i tried v9s described method and then i came to know finally that H: is actually dirty. So what to do now to make it clean :D

Most usually dirty drive error is due to some virus. Try checking it with windows defender. Otherwise use Surf Exel! :)

I was having kinda same problem

well dude I was getting an error on a 8gb SSD, and on every bootup the scanning started, and the scan did not complete either saying

An unspecified error has occurred

or

something like can not repair files due to less free space in drive.....

after googling I found a remedy and a cure :

Remedy: Forcefully disable autochk at bootup by editing registry (method mentioned above by v9s)

Cure: Use a windows xp bootable CD, and go into Recovery Console, and use chkdsk from there

chkdsk H: /r

the chkdsk from recovery console fixed the problem

[quote=", post:, topic:"]

Well, i tried v9s described method and then i came to know finally that H: is actually dirty. So what to do now to make it clean :D
[/quote]

This should make your drive undirty lol! :

Once Windows has fully loaded, bring up another CMD prompt and type and now you want to do a Chkdsk manually by typing “Chkdsk /f /r g:”.(where “g” is the letter of your drive) This should take you through 5 stages of the scan and will unset that dirty bit. Finally, type “fsutil dirty query g:” and Windows will confirm that the dirty bit is not set on that drive.