Cant send long sms

When I tried ti 4ward long sms my samsung gio automaticall converts it to mms... Any solution?

Disable GPRS and then try to send it.

Well On Andriod devices you can only send 480 words text at a time.

Install either "Go SMS Pro" or Handcent SMS. That would stop converting it to MMS. Also once you have got Gingerbread, you can do this to cure this issue:

http://forum.xda-developers.com/showthread.php?t=1171541

[quote=“waqar789, post:3, topic:15560”]

Well On Andriod devices you can only send 480 words text at a time.

[/quote]

You mean all android devices or only Gio ? Haven’t checked my self on Gio, but will check today.

handcent doesnt work.. I cheked already.....

I had read some where that android 2.3 is not available for pakistan...? If it is not true How can i upgrade? is it safe to upgrade?

I also had the exact same problem, and went the GO SMS pro route. Haven't opened the stock app since. It has loads of other features that you will just love too. Go through all of its settings when you install it. Disabling "Delete old messages" on both Go SMS and stock one is a good idea. And enabling scheduled sms backups too.

This is a reported problem with Samsung Android phones. My friend's Galaxy S does that as well. You need to install a custom sms app from the Android market. Here are the options:

Handcent SMS

Go SMS Pro

Pansi Messaging