Browsing Problem - Have to keep clicking "Try Again"

I've often been experiencing this problem before that websites just don't open and the same message comes on Mozilla that usually appears when internet is not on. I have to keep clicking "Try Again" and eventually it works out after 2-3 tries. But in some cases, it can take a lot more than that.

My dropbox had also not been working due to this very problem. It never managed to connect to dropbox server and I had to actually activate a proxy just to sync all my dropbox files. Thankfully, dropbox is finally working alright today atleast, after days of trouble.

I understand that these problems are a side effect of the mass-censorship implemented by ptcl but the scale at which I'm experiencing it is just unreal. These days, even mirc can occasionally take about 3-4 tries to get connected. Is anyone else experiencing these problems?

Use openDNS or Google

8.8.8.8
8.8.4.4

Yeah prolly a dns issue... Try Google dns what zohair wrote

Sent from MI2 using the flu-network and fireplace at the Burrow

facing same problem with Ptcl DNS :s

Also having some browsing problems with worldcall as well.

[quote=“Zohair, post:2, topic:20460”]

Use openDNS or Google

8.8.8.8

8.8.4.4

[/quote]

um, how? Don't know much technical knowledge of this so a little help is appreciated.

[quote=“kellhus, post:6, topic:20460”]

um, how? Don't know much technical knowledge of this so a little help is appreciated.

[/quote]

here you go

http://bit.ly/1e4kRZr

problem solved..

btw use this http://www.opennicproject.org/ , not google name servers, i.e. if you care about it

For someone who knows nothing of a dns server or opendns, there were far too few cues to make me google that. And OpenDNS wiki page was pretty confusing.

Used google dns because I managed to find their ipv6 addresses easily. Could only find ipv4 for opennic. Been using it for 2-3 days now and almost everything is fine now. Sites browse correctly, mirc is connecting easily... unfortunately, dropbox is still not connecting. It takes hotspot shield to make it work. Anyone else having this problem?

Thanks for the fix btw.

I wonder what's going on with ptcl...a site which used to open fine before now will only work if i use hotspot shield.

anyone know why that's happening??